Back to overview
Degraded
Login and Slow Loading Issues
Oct 9, 2025 at 8:19am UTC
Affected services
Login, Logout and User Management
Resolved
Oct 9, 2025 at 12:50pm UTC
The issue with slow performance and login errors has now been resolved. The underlying network problem with our cloud provider has been fixed, and all systems are now fully operational. Thank you for your patience.
Affected services
Created
Oct 9, 2025 at 8:19am UTC
We are aware of an issue causing slow page loads and login problems for some users. This is linked to a broader network problem with Microsoft Azure. We are monitoring their status and will provide updates as we have them.
Affected services